Ayo Membuat Program Pascal/Lampiran FPC

Dari Wikibuku bahasa Indonesia, sumber buku teks bebas
Langsung ke: navigasi, cari

Pada halaman ini, diberikan daftar menu dan shortcut yang sering dipakai dalam pengoperasian FPC

Operasi File dan Window[sunting]

Setiap program Pascal disimpan dalam file yang berbeda, dan ditampilkan di layar (window) yang berbeda pada saat sedang dimodifikasi. Oleh karena itu, perlu dipelajari menu atau tombol pintas yang dipakai untuk operasi file, yaitu:

  • Untuk membuat program Pascal yang baru, dipakai menu File - New dengan tombol pintas Alt + F - N
  • Untuk membuka (open) program Pascal yang sudah pernah dibuat sebelumnya, dipakai menu File - Open dengan tombol pintas Alt + F - O atau tombol F3
  • Untuk menyimpan (save) program Pascal yang sedang dibuat, dipakai menu File - Save dengan tombol pintas Alt + F - S atau tombol F2
  • Untuk menyimpan dengan nama lain (save as), dipakai menu File - Save as dengan tombol pintas Alt + F - A

Sedangkan untuk operasi layar, terdapat menu atau tombol pintas:

  • Untuk mengganti layar yang tampil di muka, dipakai tombol pintas Alt + 1 sampai Alt + 9, dengan angka 1 s/d 9 melambangkan nomor layar yang terdapat di pojok kanan atas dari masing-masing layar
  • Untuk menampilkan daftar semua layar, dipakai menu Window - List dengan tombol pintas Alt + W - L atau tombol Alt + 0
  • Untuk membuat layar memenuhi seluruh area kerja FPC (full screen) dipakai menu Window - Zoom atau tombol pintas Alt + W - Z atau tombol F5
  • Untuk mengubah ukuran layar atau memindahkan lokasi layar, dipakai menu Window - Size/Move atau tombol pintas Alt + W - S atau tombol Ctrl + F5. Kemudian untuk memindahkan lokasi layar dapat dipakai tombol arah panah. Sedangkan untuk mengubah ukuran layar, tahan tombol Shift lalu ubahlah ukuran memakai tombol arah panah. Apabila sudah selesai mengubah/memindahkan layar dapat ditekan tombol Enter untuk kembali mengetik. Operasi ini juga dapat dilakukan dengan memakai tetikus, untuk memindahkan dapat ditahan dan ditekan tombol kiri tetikus di posisi garis layar sebelah atas/kiri. Sedangkan untuk mengubah ukuran layar, dapat ditahan dan ditekan tombol kiri tetikus di posisi pojok kanan bawah.
  • Untuk menutup (close) layar program Pascal yang sudah selesai dibuat/dimodifikasi, dipakai menu Window - Close dengan tombol pintas Alt + W - C atau tombol Alt + F3. Bisa juga dengan memakai tetikus dengan menekan kotak berwarna hijau di pojok kiri atas layar

Mengetik dan Memodifikasi Program Pascal[sunting]

Untuk menyorot (block) suatu kumpulan teks di FPC, dapat dilakukan dengan menahan dan menarik tombol kiri tetikus (mouse) di atas kumpulan teks yang akan disorot. Sedangkan dengan memakai papan ketik (keyboard), dapat dilakukan dengan cara menahan tombol Shift diikuti tombol anak panah untuk menyorot bagian teks yang diinginkan.

Sedangkan untuk melakukan operasi duplikasi (copy), dapat dipakai menu Edit - Copy dengan shortcut Alt + E - C atau tombol Ctrl + Ins. Untuk operasi potong (cut), dipakai menu Edit - Cut dengan shortcut Alt + E - T atau tombol Shift + Del. Untuk menghapus (del), dipakai menu Edit - Clear dengan shortcut Alt + E - L atau tombol Ctrl + Del. Dan untuk operasi peletakan (paste) dari operasi copy atau cut yang sebelumnya, dipakai menu Edit - Paste dengan shortcut Alt + E - P atau tombol Shift + Ins.

cara untuk undo dan redo + tombol shortcut-nya

cara untuk mengubah indentasi + tombol shortcut-nya

Compile dan Run[sunting]

definisinya + caranya + tombol shortcut-nya

cara melihat hasil run-nya + tombol shortcut-nya

Redirection (Membelokkan dari Input atau Output)[sunting]

gunanya + caranya